tag: logging

Better name for Logging Levels

I find logging levels quite difficult to understand and use. What’s informative? versus what is a warning? I’ve seen this naming scheme somewhere a while ago, (ref required), I wished this was more common: export const makeLogger = (name: string) => { const prefix = `[${name}]`; return { inTestEnv: (msg: string, ...args: any[]) => console.debug(`${prefix}: ${msg}`, ...args), inProdEnv: (msg: string, ...args: any[]) => console.info(`${prefix}: ${msg}`, ...args), toInvestigateTomorrow: (msg: string, ...args: any[]) => console.